Questo sito utilizza cookie, per migliorare la tua esperienza e offrire servizi in linea con le tue preferenze. Chiudendo questo banner, scorrendo questa pagina o cliccando qualunque suo elemento acconsenti all'uso dei cookie. Se vuoi saperne di più o negare il consenso a tutti o ad alcuni cookie vai alla sezione Cookie Policy.

 Documentazione Gantry 5

Per creare template Joomla! di qualità

Valutazione attuale: 0 / 5

Stella inattivaStella inattivaStella inattivaStella inattivaStella inattiva
 
Come qualsiasi altro framework, anche Gantry ha bisogno dei requisiti minimi per un corretto funzionamento.  Fate attenzione e assicuratevi che siano rispettati prima di iniziare a utilizzare Gantry. Dalla versione 5.3.1, per un corretto funzionamento, l'interprete PHP dovrebbe essere aggiornato alla versione 5.6.

Nota:

Approfondimenti nell'articolo PHP 5.4: End of Support

Joomla 3.4+

Si raccomanda di utilizzare sempre la più recente versione stabile di Joomla. In questo momento la versione 3.5.1 è la versione attuale stabile di Joomla.

PHP 5.6+

  •  cURL
  •  Librerie OpenSSL
  •  Supporto Multibyte String

Nota:

Se avete abilitato xdebug, assicuratevi che il valore di xdebug.max_nesting_level è superiore a 100. Sembra che 256 è un valore sufficiente.

BROWSER

Requisiti del browser per l'amministrazione e gestione di un sito con Gantry 5 sono:
  •  Google Chrome 41+
  •  Firefox 36+
  •  Safari 8+
  •  Opera 28+
  •  Internet Explorer 10+ (Supporto limitato con IE 9)

Nota:

Se volete amministrare il sito da un dispositivo Android, assicuratevi che ha pieno supporto per flex.

Ambienti di sviluppo

E' preferibile lavorare in un ambiente locale quando si lavora con Gantry e non solo. Ecco un'elenco di strumenti che permettono di configurare un ambiente locale su qualsiasi sistema operativo:
Mac OS X
  •  MAMP & MAMP Pro
  •  XAMPP for Mac OS X
  •  ZEND Server Community Edition
  •  Mac Port

Windows
  •  EasyPHP
  •  WampServer
  •  ZEND Server Community Edition
  •  XAMPP for Windows

Linux
  •  LAMP Bundle
  •  XAMPP for Linux
  •  ZEND Server Community Edition